Adb.exe konnte nicht gefunden werden – nach dem Upgrade auf Android SDK 2.3

Ich habe mein Android SDK auf Version 2.3 und Android Development Tools 8.0.0 aktualisiert. Jetzt in Eclipse bekomme ich eine Fehlermeldung:

Konnte nicht finden C: \ Programme (x86) \ Android \ android-sdk-windows \ platform-tools \ adb.exe!

Und ich habe diese Datei nicht. Wie kann ich das beheben? Ist es ein Fehler in der Android SDK 2.3 oder Android Development Tools 8.0.0?

  • "Kann keine Systembibliothek für das Projekt erhalten", nachdem ich auf Android SDK 2.3 und ADT 8.0 aktualisiert habe
  • Wie kann man javadoc oder Quellen an jars im libs-Ordner anhängen?
  • 18 Solutions collect form web for “Adb.exe konnte nicht gefunden werden – nach dem Upgrade auf Android SDK 2.3”

    Ich habe einfach "Hilfe" -> "Check for uppdates" in Eclipse. Dann habe ich überprüft jedes Update möglich (ich hatte 2) akzeptiert, wartete auf die Updates zu vervollständigen, neu gestartet Eclipse und dann alles wurde behoben!

    Ich hatte einige neue Build-Fehler nach dem Update, aber, so etwas wie:

    Fehler: Mehrfache Substitutionen im Nicht-Positionsformat angegeben; Hast du das formatierte = "falsche" Attribut hinzugefügt

    Ich werde nicht erklären, die Lösung für dieses Problem, da dieser Beitrag ist nicht darüber! Aber; Die Lösung für dieses Problem finden Sie in der Google Groups-Gruppe Android Developers Post, SDK 2.3: Get "Multiple Substitutionen im Nicht-Positionsformat" Fehler .

    Ich hatte das gleiche Problem. Ich habe es gelöst, indem ich zu helfen -> Nach Updates suchen und die aufgeführten Komponenten in Eclipse aktualisieren.

    Du musst den PATH aktualisieren, um ADB in "Platform-Tools" zu sehen.

    Unter Mac OS X öffnen Sie Ihr Terminal und fügen Sie die folgende Zeile zu Ihrem .bash_profile hinzu:

    export PATH=${PATH}:/Users/yourname/Library/android-sdk/tools:/Users/yourname/Library/android-sdk/platform-tools: 

    Dein .bash_profile befindet sich bei

     ~/.bash_profile 

    @Jonas In deiner Eclipse Klicken Sie auf Hilfe> Nach Updates suchen. Dies wird das ADT-Plugin aktualisieren. Das neue ADT-Plugin weiß, wo man apt und adb finden kann. Jus tun dies und Ihr Problem wird behoben werden,

    EDIT: Siehe das Bild. Installiere die ersten beiden Artikel auch. ein Alt-Text

    Meine adb.exe fehlte Also habe ich das Android 2.3 SDK deinstalliert und es wieder installiert. Jetzt habe ich eine adb.exe und es funktioniert besser. Meine erste Installation die meisten haben gescheitert, ohne es für mich zu veranlassen.

    Was ich getan habe…

    1. Schloss meine Projekte und verließ Eclipse
    2. Ausgeführt [MYDRIVE]: [MYANDROIDPATH] \ android-sdk-windows \ tools \ android.bat
    3. Ausgewählte "Verfügbare Pakete" -> "Android Repository" und installiert alles aufgelistet
    4. Schloss den Installationsschirm und verließ das android.bat DOS-Fenster
    5. Aktualisiert die Umgebungsvariable PATH um "[MYDRIVE]: [MYANDROIDPATH] \ android-sdk-windows \ platform-tools"
    6. Begann Eclipse und bekam Fehlermeldung … geklickt: Hilfe -> Nach Updates suchen
    7. Lassen Sie es "Android DDMS", "Android Dev Tools", (und Mercurial)
    8. Starten Sie Eclipse neu
    9. Klicken Sie auf: Fenster -> Voreinstellungen -> überprüft, dass der Pfad "[MYDRIVE]: [MYANDROIDPATH] \ android-sdk-windows" ist. Klicken Sie auf: Übernehmen -> OK
    10. Neu begonnen Eclipse (nur um sicher zu sein), öffnete meine Projekte … zurück zur Arbeit!

    Mein Antivirus hat die Datei adb.exe entfernt, als ich versuchte, mein Projekt zu starten, was ich tun musste, um Android SDK Platform-tools neu zu installieren und es zu reparieren

    Bildbeschreibung hier eingeben

    Es ist jetzt unter Plattform-Tools. Sie müssen es mit dem Android-Tool installieren, um das Paket "Plattform-Tools" auszuwählen.

    Ich weiß, es ist dumm.

    Ich hatte das gleiche Problem. Ich musste die Eklipse dreimal neu starten und neu starten, und dann funktionierte es. Oh, und ich musste auch alle offenen Projekte schließen.

    Dies löste mein Problem, dass, obwohl ich den Ordner Pfad in meinem Plattform-Tools-Verzeichnis (die die adb.exe enthalten), würde es nicht aktivieren Sie die OK / Apply-Taste. Ich dachte, ich hätte das ADT Plug-In installiert (ich habe etwas installiert) aber anscheinend nicht das Richtige.

    Gehen Sie hier und folgen Sie diesen Anweisungen: http://developer.android.com/sdk/eclipse-adt.html

    Starten Sie AVD Manager aus der Befehlszeile
    Installierte Pakete Aktualisieren Alle
    Akzeptieren, um alle zu aktualisieren

    Starten Sie Eclipse-> Hilfe-> Nach Updates suchen -> Alle aktualisieren
    Eclipse neu starten

    Sie müssen auch ADT-Plugin für Eclipse aktualisieren, es sucht nach adb im richtigen Verzeichnis, zumindest funktioniert es gut für mich.

    Ich habe auch das ADT Plugin für Eclipse aktualisiert, obwohl ich ursprünglich nur das Eclipse Plugin vor drei Tagen geladen habe. Das Aktualisieren des Plugins löste das fehlende adb.exe Problem.

    Ich hatte das gleiche Problem nach der Installation der 2.3 SDK, Aktualisierung der Eclipse ADT Plugin gelöst das Problem. Ältere ADT-Plugins beziehen sich immer noch auf den Ordner SDK / Tools.

    (Ich benutze JDK 1.6, Eclipse Galileo SR2)

    Bitte nicht, dass einschließlich adb.exe Pfad in der Umgebung PATH-Variable ist nur für den Zugriff auf adb über Kommandozeile erforderlich.

    Ich folgte den folgenden Schritten – und habe eine Arbeitsumgebung auf MAC und Windows:

    1. Ich habe den Weg zu Tools sowie Plattform-Tools in der Android-Sdk-Ordner gesetzt als so:

      • Anhängen an PATH in .bashrc und (ich habe alles von .bash_profile) (MAC)
      • Anhängen an PATH Umgebungssystemvariable (Windows)
    2. Unzipped SDK zu / Developer / SDKs (Mac) und in D: auf Windows (nachdem ich es in C: früher ein alles in einem Crash verloren habe :)) – für Windows kann man die ausführbare Datei von Google verwenden.

    3. Installieren Sie die Android Repositories und Add-ons (für Google API)

      • Gehen Sie zu bash prompt (indem Sie auf Terminal in Utilities) und geben Sie Android (dies öffnet sich der AVD und SDK Manager (Mac)
      • Klicken Sie auf Setup.exe im SDK-Ordner (Windows)
      • Wählen Sie Verfügbare Pakete im linken Fensterbereich. – Öffnen Sie Drittanbieter-Add-ons und überprüfen Sie Google Inc für Google-APIs. (Ich persönlich habe alles überholt, um in der Zukunft hinzuzufügen, wenn nötig)
      • Klicken Sie auf Ausgewählte installieren.
    4. AVDs erstellen

      • Wiederholen Sie den AVD und den SDK Manager wie im früheren Schritt
      • Klicken Sie im linken Fensterbereich auf Virtuelle Geräte.
      • Name: AVD_2.3 für Level 9, 1024 MiB und Klick OK AVD_2.3_GA für Level 9 Google API, 1024 MiB und Klick auf OK. Und so weiter für die anderen Levels
    5. Update Eclipse ADT Plugin

      • Gehen Sie zu Eclipse -> Hilfe-> Installieren Sie neue Software-> Link der verfügbaren Software, und wählen Sie auf der Android-Plugin-Auswahl und klicken Sie auf Update .. (dies ist extrem wichtig, sonst erhalten Sie den Fehler von adb nicht in der nächsten gefunden Schritt.
    6. Geben Sie den Android SDK-Standort in Eclipse an

      • Wählen Sie Eclipse Preferences-> Android (MAC)
      • Wählen Sie Windows-> Voreinstellungen-> Android (Windows)
      • Navigieren Sie zum Pfad zum SDK-Ordner (nicht die Werkzeuge oder einen anderen Ordner) und klicken Sie auf OK. Jetzt musst du nicht den Adb-Fehler bekommen 🙂 Wenn du alles richtig gemacht hast, solltest du alle AVDs sehen, wenn du es nicht siehst, schließe den Dialog und öffne ihn wieder, du musst alle AVDs sehen, die du in Schritt 3 erstellt hast.

    Ich konnte den Fehler wie folgt beheben. 1. Gehen Sie zu Eclipse Klicken Sie auf Hilfe> Nach Updates suchen 2. Gehen Sie zu Windows-> Android SDK und AVD Manager-> Installieren von Paketen-> Android SDK-Tools (installieren). 3. Eclipse neu starten

    Ich habe das gleiche Problem und löste dies durch die folgenden: 1) "Hilfe" -> "Check für uppdates" in Eclipse 2) GOTO android sdk lib – sdk manager – installieren Sie "Android SDK Plattform-Tools"

    Das ist viel Glück

    Gehen Sie zu "Hilfe" -> "Überprüfen auf uppdates" in Eclipse. Dann überprüfe jedes Update möglich, warte auf die Updates zu vervollständigen, neu gestartet Eclipse und dann ist alles repariert!

    Rufen Sie mich albern an, aber wenn Sie gerade die SDK \ Readme.txt lesen

    $ Cat SDK \ Readme.txt
    Willkommen im Android SDK!

    Das Android SDK Archiv enthält jetzt nur noch die Werkzeuge. Es wird nicht mehr mit einer bestimmten Android-Plattform oder Google-Add-on besetzt. Stattdessen verwenden Sie den SDK-Manager, um SDK-Komponenten wie Plattformen, Tools, Add-Ons und Dokumentation zu installieren oder zu aktualisieren.

    Um mit der Entwicklung von Anwendungen zu beginnen, müssen Sie mindestens eine Version der Android-Plattform mit dem SDK Manager installieren.

    Dies erfordert eine Internetverbindung, also, wenn Sie planen, das SDK offline zu verwenden, stellen Sie bitte sicher, die notwendigen Bestandteile während online zu downloaden.

    Um den SDK Manager zu starten, führen Sie bitte das Programm "tools / android" aus.

    Von der Befehlszeile aus können Sie auch direkt ein Update ausführen, indem Sie: tools / android update sdk ausführen

    Weitere Informationen finden Sie auf der Android-Website unter http://developer.android.com

    Ich bin jetzt müde, ich muss mich ausruhen, das hat mich von all meiner Energie entwässert.

    Das Android ist ein Google Android Fan-Website, Alles über Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.