Tag: android gradle

Android Unit Testing von Kategorien

Ich möchte in der Lage sein, zwei (oder mehrere) Testaufgaben für mein Android-Projekt zu haben, wo der Unterschied ein anderer Satz von Junit-Kategorien ist, um zu schließen / auszuschließen. Mit dem gradle Java Plugin kann ich so etwas machen task testFast(type: Test) { useJUnit { includeCategories 'foo.Fast' excludeCategories 'foo.Slow' } } task testSlow(type: Test) { […]

App: mergeDebugResources Fehler in Android Studio nach dem Upgrade

Ich bekomme einen Fehler beim Erstellen / Ausführen des Android Studio Projektes. Fehler: : App: mergeDebugResources FEHLER Fehler: Ausführung fehlgeschlagen für Task ': app: mergeDebugResources'. Einige Datei knirscht fehlgeschlagen, siehe Protokolle für Details Ich habe die Post auf SO gegangen und habe die folgenden Dinge getan, um es zu beheben, aber ich bin immer noch […]

Was ist der richtige Weg, um Android-Anwendung zu setzen, wenn Sie Aroma-Dimensionen verwenden?

Ich benutze Geschmack Dimensionen in meinem Projekt, und ich habe mit einer for-Schleife, um die Anwendung auf meine generierten Aromen gesetzt: flavorDimensions "appname", "brand" productFlavors { user { dimension "appname" } installer { dimension "appname" } branda { dimension "brand" } brandb { dimension "brand" } brandc { dimension "brand" } brandd { dimension "brand" […]

Android Studio: Gradle Sync scheitert mit support-v4-24.1.1.jar

Ich bekomme gradle Problem. Hier ist unten Problem in gradle Nachricht, während Synchronisierung in gradle Unsere Android Studio version is 2.1.2 . Fehler: Es ist ein Problem beim Konfigurieren des Projekts ': LetMeCall_Store' aufgetreten. Konnte nicht finden-support v4.jar (com.android.support:support-v4:24.1.1). Gesucht an folgenden Orten: https://jcenter.bintray.com/com/android/support/support-v4/24.1.1/support-v4-24.1.1.jar Unten ist gradle file apply plugin: 'com.android.application' android { compileSdkVersion 24 […]

Com.android.dex.DexException: Mehrere Dex-Dateien definieren Landroid / Support / Annotation / AnimRes;

Hallo Ich arbeite an einem Projekt, für das ich Android Studio verwende. Ich habe alles eingerichtet, aber wenn ich mein Projekt laufe, bekomme ich unter Fehler. Ich konnte es nicht für die letzten 2 Tage lösen. Was könnte das Problem in meinem Projekt sein, das diesen Fehler verursacht Bitte helfen Sie, wenn jemand darüber Bescheid […]

Gradle Warning "nicht spezifiziert hängt von Bibliotheken, sondern ist ein Jar" beim Kompilieren eines Android-Modul in einem benutzerdefinierten Java-Bibliothek-Modul

Ich bin ein Newbee in Gradle. Ich habe eine einfache Projektstruktur (gezeigt unten) mit einem Haupt-Android-App-Modul, einem Android-Modul (myandroidlibrary) und einem reinen Java-Modul (myjavalibrary). Sie haben einfache Abhängigkeiten, App -> myjavalibary und myjavalibary -> myandroidlibrary (siehe unten). Gradle-Dateien Schnappschüsse sind auch unten angegeben. Allerdings, während Sync der Gradle es produziert folgenden Fehler: D:\MyTestCodes\MyTestApplication\app\build.gradle Warning:Module version […]

Gradle-android-scala-plugin gibt "Kann nicht passenden Konstruktor" Fehler finden

Wenn Sie diesen Beispielcode in Android Studio importieren, wird dieser Fehler angezeigt: Fehler: (17, 0) Der passende Konstruktor konnte nicht gefunden werden: org.gradle.api.internal.tasks.DefaultScalaSourceSet (java.lang.String, org.gradle.api.internal.file.BaseDirFileResolver) Build.gradle: buildscript { repositories { mavenCentral() } dependencies { classpath "com.android.tools.build:gradle:2.0.0" classpath "jp.leafytree.gradle:gradle-android-scala-plugin:1.4" } } repositories { jcenter() } apply plugin: "com.android.application" android{ compileSdkVersion "android-23" buildToolsVersion "23.0.1" } apply plugin: […]

ProjectFilesBackup-Ordner im Android-Studio-Projekt für die neueste Version

Wenn wir das Android-Studio mit der neuesten Version aktualisieren und das Plugin auch aktualisieren. Ein Ordner namens projectFilesBackup erstellt, wenn wir unser altes Android-Studio-Projekt in der neuesten Android-Studio-Version öffnen. Meine Frage ist, warum dieser Ordner erstellt wurde, warum dies ist und wie lange sollten wir diesen Ordner in unserem Projekt-Ordner zu halten?

Fehler beim Kompilieren von Android-Projekt nach dem Aktualisieren von FindBugs auf 3.0.1

Nach der Aktualisierung von Findbugs Plugin bis zu 3.0.1 Version kann ich kein Multimodulprojekt in Android Studio kompilieren. Auch ich benutze "com.google.code.findbugs:annotations:3.0.1" Abhängigkeit für die Verwendung von FindBugs-Annotationen (zB @SuppressFBWarnings ). Bei der Zusammenstellung des Projektes bekomme ich folgende Fehler: Execution failed for task ':presentation:packageAllDevelopDebugClassesForMultiDex'. > java.util.zip.ZipException: duplicate entry: javax/annotation/CheckForNull.class Wie kann ich es beheben?

Wie man statische Bibliotheken (.a Dateien) mit APK mit gradle experimentelles Plugin 0.2.0 in Android Studio verknüpft

Es gibt zwei Dinge in meinem Projekt. Ich ndk-build eine statische Bibliothek mit ndk-build Verknüpfe diese statische Bibliothek mit der vorhandenen Anwendung in Android Studio. Habe viele Fragen und versuchte viele Antworten. Aber keiner von ihnen arbeitet für mich. Hier sind meine Zweifel, Wo sollten eigentlich die statischen Bibliotheken platziert werden? Wie kann ich das […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.