Tag: gradle

Android BuildConfig Probleme beim Hinzufügen von Eigenschaften durch Gradle

Ich füge noch einige Eigenschaften in BuildConfig über build.gradle wie unten release_prod{ buildConfig "public static final String ENVIRONMENT = \"prod\";" } release_dev{ buildConfig "public static final String ENVIRONMENT = \"dev\";" } Das Problem ist, wenn ich von gradle baue, es geht gut, aber wenn ich kompilieren Projekt in Eclipse bekomme ich Fehler, weil diese Variable […]

Code Coverage im Android Studio mit Sonar & Gradle

Ich versuche, Code-Coverage für ein neues leeres Android-Projekt mit Gradle in Android Studio zu bekommen. Ich habe es geschafft, Sonar zu arbeiten, aber ich kann es nicht scheinen, es für die Codeabdeckung herauszufinden. (So ​​etwas noch nie gemacht) Ich habe bei JaCoCo geschaut, aber es ist nicht mit Android kompatibel. Das gleiche gilt für Cobertura. […]

Finde ich zwei gradle android plugin – Gibt es eine Beziehung zwischen den beiden?

Ich habe versucht zu erfahren, wie man Android-Anwendung mit Gradle zu bauen. Zu meiner Überraschung fand ich zwei Referenzen, eine von jvoegele und eine andere von Android Tools Project Website. Sie scheinen eine andere prima facie zu sein. Also meine Frage ist, warum gibt es zwei Varianten? Gibt es eine Beziehung zwischen den beiden? Was […]

AndroidStudio – Gradle Refresh fehlgeschlagen

Ich war mit der up-to-date-Version von Android-Studio, um meine App für Android zu bauen. Die gradle wrapper stellte die gradle installation ein und das projekt wurde ohne fehler gebaut Irgendwann habe ich jedes Mal, wenn ich neu gestartet habe, einen Fehler bekommen. Gradle: Es ist ein Problem aufgetreten, das das Projekt ': App' konfiguriert. Konnte […]

Fehler beim Android-Studio beim Erstellen eines neuen Projekts

Ich habe diese Fehlermeldung bekommen, während ich versuchte, ein neues Projekt im Android Studio zu erstellen: Failed to import Gradle project: Error unmarshaling return header; nested exception is: java.net.SocketException: Connection reset

Wie kann man runProguard für die android-Bibliothek machen? Gradle Plugin?

Ich möchte ProGuard auf Release-Build meiner Android-Bibliothek laufen lassen. Unten ist meine build.gradle Datei, die in meinem Projekt ist. buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.5.+' } } apply plugin: 'android-library' repositories { mavenCentral() } android { compileSdkVersion 18 buildToolsVersion "18.0.1" defaultConfig { minSdkVersion 10 targetSdkVersion 18 } sourceSets { main { […]

Add .idea / Bibliotheken zu .gitignore mit Android Studio (und Gradle) eine gute Idee?

Mit dem Wechsel zum Gradle-Build-System habe ich eine Reihe von * .xml-Dateien bemerkt, die dem .idea / Bibliotheken-Projektverzeichnis hinzugefügt wurden. Ich würde davon ausgehen, dass das ist, wie Android Studio / IntelliJ Bibliotheken mit dem Projekt verbindet. Ist es ok / empfiehlt, .ida / bibliotheken zu .gitignore hinzuzufügen? Da gradle alle Abhängigkeiten behandelt, würde ich […]

"Sie haben keine Ansicht angegeben, um als Inhalt für Popups zu verwenden"

Also habe ich versucht, Leaderboards / Achievements in meinem Spiel zu implementieren, und ohne jede Art von Implementierung läuft das Spiel ganz gut. Ich habe erfolgreich die google-play-services-lib importiert und über BaseGameUtils kopiert. Aber wann immer ich versuche, Setup für ein GameHelper-Objekt aufzurufen, stürzt es ab. LogCat gibt folgende Fehlermeldung an: getCSCPackageItemText() You have not […]

So aktualisieren Sie Apache HttpClient Versionen auf Android

Ich habe HttpClient 4.3.3 für Android zu meiner build.gradle Datei hinzugefügt, wie von Apache beschrieben , aber meine App hat sich nicht in Größe geändert. Aus diesem Grund bin ich mir ziemlich sicher, dass, während meine IDE httpclient-android-4.3.3 als externe Bibliothek zeigt, es nicht wirklich aufgenommen und von meiner App verwendet wird. Ich habe versucht, […]

Konnte nicht finden com.android.support:support-v13:19.0.0

Seit der letzten Runde von Updates bekomme ich diesen Fehler. Gradle absolut, kategorisch weigert sich, die v13-Unterstützungsbibliothek zu finden. Ich habe folgendes ausprobiert: Installation des neuesten Android Support Repository sowie der neuesten Android-Support-Bibliothek Die ersten beiden vorschläge von hier Angabe der letzten Gradle (0.12. +) Im Build-Skript Spezifizierung verschiedener Versionen der v13-Bibliothek Ich kann die […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.