Tag: gradle

Gradle-Synchronisierung fehlgeschlagen: Bibliotheksfenster können nicht geladen werden – amd64 \ native-platform.dll

Aktualisiert von Android Studio 1.4 auf 2.0, und hatte die IDE meine gradle Abhängigkeit von 2.0 von 1.x im build.gradle ändern: dependencies { classpath 'com.android.tools.build:gradle:2.0.0' } Aktualisiert die Projekt-Gradle-Version auf 2.10. Als ich versuchte, ein Projekt mit den Gradle-Dateien zu synchronisieren oder das Projekt zu aktualisieren, bekomme ich nun den folgenden Fehler: Gradle sync failed: […]

Installiert die neueste Version von Android Studio, Ausnahme trat auf, als ich das Projekt baute?

Ein Android-Projekt, es war gut mit der älteren Version von Android Studio. Aber nachdem ich die IDE-Version aktualisiert habe, wird eine Ausnahme auftreten, wenn ich das Projekt whith gradle baue. Hier ist das Problem: Fehler: Ausführung fehlgeschlagen für Aufgabe ': jellyrefresh: compileReleaseJava'. Wenn du gradle mit Java 5, 6 oder 7 laufst, musst du den […]

Gradle build: Execution fehlgeschlagen für Task ': app: lint'

Ich benutze Android Studio 2.0 und ich habe versucht, mein Programm zu laufen, wenn etwas Seltsames passiert ist. Ich lief den Bau Befehl der Grade und ich habe diese Fehler: FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ':app:lint'. > Lint found errors in the project; aborting build. Fix […]

Gradle zeigt Fehler für Support Library: "Modulversion com.android.support:support-v13:19.0.1 hängt von Bibliotheken ab, ist aber keine Bibliothek selbst"

Dies ist, was mein build.gradle sagt: apply plugin: 'android' apply plugin: 'crashlytics' apply from : '../gradle/checkstyle.gradle' apply from : '../gradle/pmd.gradle' compileSdkVersion 19 buildToolsVersion "19.0.3" defaultConfig { minSdkVersion 17 targetSdkVersion 19 } Aber ich sehe diesen Kompilationsfehler: Gradle 'mobi-client-connect-android-mobile' project refresh failed: Module version com.android.support:support-v13:19.0.1 depends on libraries but is not a library itself

Importieren der Drag-Sort-Listenansicht-Bibliothek im Android Studio-Gradujekt-Projekt

Ich versuche, die Drag-Sort-Listenansicht Android-Bibliothek in meine Anwendung in Android Studio zu importieren. Ich hatte keine Probleme mit Eclipse. Git-Repository für die Bibliothek: https://github.com/bauerca/drag-sort-listview

Minify android app aber nicht verschleiern es

Wenn ich meine App nicht beende, erreiche ich die maximale Methodenzahl und das Erstellen der dex-Datei scheitert. Dies kann vermieden werden, indem es in minify build.gradle . Der Nachteil ist jedoch, dass jetzt der Code verschleiert wird. Dies ist für das Release-Build ok, aber es ist problematisch für ein Debug-Build. Gibt es eine Möglichkeit, Gradle […]

Gradle: applicationVariants.all überspringt eine Variante

Ich benutze Gradle, um mein Android-Projekt zu kompilieren: buildTypes { release { signingConfig signingConfigs.release applicationVariants.all { variant -> def file = variant.outputFile def fileName = file.name fileName = fileName.replace(".apk", "-renamed".apk") variant.outputFile = new File(file.parent, fileName) } } } Nicht alle Ausgabedateien werden umbenannt, es überspringt immer 1 Datei. Warum? myapp-debug-unaligned-renamed.apk <-renamed, OK! myapp-release.apk <-NOT renamed, […]

Jvm Optionen in Android, wenn Sie gradlew Test laufen

Ich habe ein Projekt, das mit Robolectric für Unit-Test Zweck. Dieses Projekt verwendet Robolectric 3.0 und muss -ea hinzufügen und Optionen in Virtual Machine-Optionen verschieben. In Android Studio habe ich eine neue JUnit-Konfiguration in Run > Edit Configurations… und dann VM Options auf -ea -noverify . Auf diese Weise habe ich Erfolg, meinen Unit-Test zu […]

Fehler beim Import eines Eclipse-Projekts in Android Studio

Ich versuche, ein Projekt in Eclipse zu Android Studio zu importieren. Beim Importieren bekomme ich folgende Fehlermeldung: "There are unrecoverable errors which must be corrected first" Library reference ../../../../workspace/android-support-v7-appcompat could not be found Ich habe versucht, kopieren appcompat Ordner in das Stammverzeichnis des Projekts, noch gleichen Fehler. Wie kann ich das lösen? Bitte beachten Sie […]

Fehler: (3, 0) Ursache: org / apache / commons / lang3 / StringUtils

Ich bekomme den folgenden Fehler Fehler: (3, 0) Ursache: org / apache / commons / lang3 / StringUtils Wenn ich versuche, Datenbindung in meinem Android-Projekt hinzuzufügen. Meine Abhängigkeiten sind: // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.0.0-alpha7' classpath 'me.tatarka:gradle-retrolambda:3.2.2' […]

Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.