Aviary stürzt auf Android L ab (5.0)

War nur testen meine app und herausgefunden, dass nach dem Upgrade meiner Nexus 5 auf Lollipop / 5.0, die Aviary SDK ich in es stürzt große Zeit.

In einer Google-Suche fand ich eine SO-Frage, die gestern mit dem gleichen Problem gestellt wurde, aber diese Frage wurde vom Benutzer gelöscht (ich konnte es durch den Googles-Cache ansehen).

Es sagte:

Wenn ich mein Projekt auf Android L laufe, stürze es jedes Mal mit Fehler ab: 11-20 09: 27: 38.560: A / art (13974): art / runtime / check_jni.cc: 65] JNI DETEKTIERTE ERROR IN ANWENDUNG: JNI GetFieldID rief an Mit ausstehender Ausnahme 'java.lang.NoSuchFieldError' in int com.aviary.android.feather.headless.moa.Moa.n_init geworfen (android.content.Context, java.lang.String, int): – 2 jemand hat eine Lösung dafür? Vielen Dank. Ps, es geht gut mit sdk <= 4.4

Mein Problem ist genau das gleiche – Es funktionierte vor-5.0 und auf meinem anderen Telefon (Galaxy S2 mit 4.1.3) funktioniert es perfekt.

  • Ist es ok, ein JSON-Array in SharedPreferences zu speichern?
  • System.getProperty ("line.separator") Vs "\ n" für Android
  • Android Studio JDK Standort ändert sich wieder auf 1.7 jedes Mal, wenn es auf 1,8 Pfad aktualisiert wird
  • Java.util.zip.ZipException: doppelter Eintrag: wie zu überwinden
  • Wie definiere ich einen neuen Charset in Java / Android?
  • Wie programmiere ich einen einfachen Musik-Sequenzer für Android (Java)
  • Wie deaktiviere ich SSLv3 in Android für HttpsUrlConnection?
  • Erhalten Sie Kartenadresse oder Standortadresse in Android
  • 4 Solutions collect form web for “Aviary stürzt auf Android L ab (5.0)”

    Die neueste Voliere sdk sowohl für Android Studio und Eclipse ist auf der Aviary Website verfügbar.

    Gradle SDK – Version 3.6.3-Gradle

    ANT SDK – Version 3.6.3-ANT

    Ich konnte die Eclipse-Version testen und auf Lollipop-Emulator testen. Es gab keinen Crash.

    Bitte geben Sie Feedback, wenn auf tatsächlichen Lollipop Android-Gerät getestet.

    Aviary Website Link Aviary Android Sdk .

    Ich bekomme den gleichen genauen Fehler. Es scheint, als hättest du hier drei Möglichkeiten.

    Entdecken Sie den Bibliotheksquellcode und versuchen Sie, den Fehler selbst zu beheben

    Warten Sie auf Aviary / Adobe, um es zu patch

    Überprüfen Sie die aktuelle Build.VERSION.SDK_INT und verweigern Sie Aviary, wenn sie größer als 19 ist.

    Ich habe herausgefunden, dass die Aktualisierung der neuesten Aviary SDK-Version das 5.0-Problem behebt – aber auch der Entwickler muss von ANT zu Gradle = Von Eclipse zu Android Studio wechseln. Es hat mir sehr lange gedauert, bis meine Projekte in AS korrekt funktionieren und in AS richtig funktionieren, aber jetzt scheint es zu funktionieren – auch Aviary.

    Wechseln Sie zu adobe creative sdk https://creativesdk.adobe.com/

    Die Aviary-Bibliothek ist jetzt dort eingebettet

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.