Die SDK-Plattform-Tools-Version (24.0.4) ist zu alt, um die mit API 25 kompilierten APIs zu überprüfen; bitte aktualisieren

Ich bekomme diesen Fehler auf die neueste Version von Android Studio und während ich sowohl Android SDK Platform API 25 als auch Android SDK Build-Tools 25 installiert habe.

  • Die Sdk-Plattform-Tools (23.1) sind zu alt, um die mit API kompilierten APIs zu überprüfen; bitte aktualisieren
  • Debug Bridge kann nicht erstellt werden, um die Adb-Version zu erkennen. Syntaxfehler: ")" Upgrade von Platform-Tools 23.0.1 auf 23.1.0 Linux-32 Bit verursacht Problem
  • 7 Solutions collect form web for “Die SDK-Plattform-Tools-Version (24.0.4) ist zu alt, um die mit API 25 kompilierten APIs zu überprüfen; bitte aktualisieren”

    Ich hatte ein ähnliches Problem. Aktualisieren von Android Studio auf Version 2.2.2 (spätestens zum Zeitpunkt dieses Schreibens) und Gradle Version auf 2.2.2 (spätestens zum Zeitpunkt dieses Schreibens) in project_name/build.gradle Datei behoben dieses Problem.

    Als Referenz ist dies meine config in project_name/app/build.gradle Datei:

     minSdkVersion = 19 targetSdkVersion = 25 compileSdkVersion = 25 buildToolsVersion = "25" supportLibraryVersion = "25.0.0" 

    Und das sind meine dependencies in der Datei project_name/build.gradle :

     buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.2.2' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } 

    Wie Vishnu sagte, Für mich Aktualisierung Android Studio und Gradle nicht das Problem beheben.

    Ich navigierte zu Tools -> Android -> SDK Manager und ausgewählte BuildTools und überprüfte für die Updates im Zusammenhang mit Plattform-Tools. Nach dem Aktualisieren und Installieren dieser, behoben mein Problem.

    Und für eine meine Freunde, wurde das Problem gelöst, nachdem Sie die oben genannten Schritte und dann navigieren zu Hilfe-> Check für Updates-> und installieren alle verfügbaren Updates.

    Angehängter Screenshot für das gleiche. Bildschirmfoto

    Ich habe das gleiche Problem, aber wenn ich tausche

     buildToolsVersion "25.0.0" 

    Auf die erste Zeile dann Problem gelöst. Dann wird die endgültige App-Klasse:

     android { buildToolsVersion "25.0.0" compileSdkVersion 25 defaultConfig { applicationId "com.***" minSdkVersion 15 targetSdkVersion 25 versionCode 0 versionName "0.0.0" } buildTypes { release { minifyEnabled true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } 
    1. Öffnen Sie AndroidMainfest.xml
    2. Klicken Sie auf das rote Symbol => Inspektion prüfen => Fehler ist weg

    Bildbeschreibung hier eingeben

    Versuche zu aktualisieren

    • Android SDK Build-Tools
    • Android SDK Plattform-Tools
    • Android SDK Werkzeuge
    • Android-Support-Repository
    • Google Play Services
    • Google-Repository

      Etc auf die neueste Version. Fehler muss weg sein

    Gehen Sie zu Gradle (app) und ersetzen Sie

      buildToolsVersion "25" 

    nach

      buildToolsVersion "24.0.4" // Or Latest installed gradle version 

    Auch wenn targetSdkVersion ist 25 dann machen diese 24

    Aktualisieren Sie Ihre Android-Sdk-Plattform-Tools auf die Revision von 24.0.4 auf 25.xx auf sdk Manager. Dann Androide Studio klicken Sie auf File-> Invalidate Caches / Restart …

    Der Fehler muss jetzt weg sein

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.