Fehler: Muss ein Pixel-Frame haben, der entweder transparent oder weiß in Android Studio ist

Ich habe gerade ein Projekt von Eclipse ins Android Studio importiert. Fast für jedes zweite Bild gibt das Android-Studio den folgenden Fehler.

Error:Must have one-pixel frame that is either transparent or white. 

Ich versuche, meine Bilder für die letzten paar Stunden zu bearbeiten, aber konnte es nicht tun. Kann mir jemand führen, was die beste Lösung dafür ist.

Warum ist es in nur Android Studio warum nicht in Eclipse.

  • Projekt mit Pfad ': mypath' konnte nicht im Wurzelprojekt 'myproject' gefunden werden
  • ADT Plugin kann nicht installieren: Fehlende Anforderung: Android Development Tools
  • Android-Abhängigkeiten verweist auf nicht vorhandene Bibliothek google-play-services_lib.jar
  • App Crashing mit Proguard aktiviert
  • Kann nicht Android-SDK aktualisieren
  • Nexus 5 USB Treiber
  • Qt C ++ - Bibliothek im Android Eclipse Projekt: QSQLITE Treiber nicht geladen
  • Fehler beim Laden der Sdk, wenn die Eclipse gestartet wird
  • One Solution collect form web for “Fehler: Muss ein Pixel-Frame haben, der entweder transparent oder weiß in Android Studio ist”

    Dies wird gezeigt, weil Sie versuchen, 9-Patch-Bilder zu bearbeiten, die nicht über die entsprechende 1-Pixel-Grenze verfügen.

    Android verwendet ein Bildformat namens 9-Patch, mit dem Sie dehnbare Bereiche in einem Bild definieren können (hier können Sie mehr darüber lesen). Um Ihr Problem zu beheben, fügen Sie entweder einen äußeren 1-Pixel dicken transparenten Rahmen zu Ihren png Bildern hinzu oder benennen Sie sie einfach von .9.png- Dateien zu .png- Dateien um

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.