Kann kein Projekt in Android Studio (libGDX) ausführen

Jedes Mal, wenn ich versuche, mein Desktop-Projekt in Android Studio auszuführen, bekomme ich sofort die folgende Fehlermeldung:

Error:com.android.tools.idea.gradle.util.Projects.lastGradleSyncFailed(Lcom/intellij/openapi/project/Project;)Z 

Kein gradle build geschieht, oder irgendeine Art von Synchronisierung. Android Studio springt gerade direkt zu diesem Fehler.

Ich habe Neustart / ungültige Caches, ich habe meinen .gradle Ordner in beiden Projekt- und Home-Locations gelöscht, ich habe das Android-Studio neu installiert, ich habe ein neues Projekt erstellt, aber ich bekomme immer noch den gleichen Fehler.

Wenn ich das gradle-Build manuell laufe, ist der Build erfolgreich abgeschlossen. Ich kann sogar das Android-Projekt ohne Probleme laufen lassen. Es ist nur das Desktop-Projekt, das mir Probleme gibt.

Irgendwelche Vorschläge würden sehr geschätzt.

Ich benutze die neueste Version von android gradle (2.3.0), und mein JDK ist die richtige Version (1.8).

Ich bekomme diesen Fehler nach der Aktualisierung auf Android Studio 2.3.

Um zu klären, vervollständigt die Gradle build / sync ERFOLGREICH.

  • Google Play Services Fehler - Fehlerbericht unverständlich
  • Android-Studio kann nicht importieren org.json.JSONObject
  • Libgdx SpriteBatch wird zur Textur übertragen
  • LibGdx GC_Concurrent läuft
  • Android.os.Bundle kann nicht in libgdx Android-Projekt gelöst werden
  • Verwenden von scene2d.ui mit libgdx: Woher kommt die Haut?
  • GestureDetector in libgdx
  • PlayN - Virtuelle Tastatur auf iOS und Android
  • One Solution collect form web for “Kann kein Projekt in Android Studio (libGDX) ausführen”

    UPDATE: Es sieht so aus, als hätte dieses Problem möglicherweise in RoboVM 2.3.2 behoben: https://github.com/MobiVM/robovm/issues/115#issuecomment-303979058


    Es klingt wie Sie vielleicht zurück zu Android Studio 2.2 zurückkehren können, die Sie hier herunterladen können: http://tools.android.com/download/studio/builds/android-studio-2-2-3

    Ich hatte das gleiche Problem. Die Fehlermeldung in "Messages" ist nicht hilfreich, aber wenn Sie zu Help->Show Log in Finder , sehen Sie einige zusätzliche Informationen, die ein wenig nützlicher ist:

     2017-03-06 17:52:27,615 [4546022] INFO - ij.compiler.impl.CompileDriver - java.lang.NoSuchMethodError: com.android.tools.idea.gradle.util.Projects.lastGradleSyncFailed(Lcom/intellij/openapi/project/Project;)Z at org.robovm.idea.components.RoboVmBuildProcessParametersProvider.getVMArguments(RoboVmBuildProcessParametersProvider.java:60) at com.intellij.compiler.server.BuildManager.launchBuildProcess(BuildManager.java:1136) at com.intellij.compiler.server.BuildManager.lambda$null$11(BuildManager.java:730) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at com.intellij.util.concurrency.BoundedTaskExecutor.runFirstTaskThenPollAndRunRest(BoundedTaskExecutor.java:178) at com.intellij.util.concurrency.BoundedTaskExecutor.access$000(BoundedTaskExecutor.java:40) at com.intellij.util.concurrency.BoundedTaskExecutor$2.run(BoundedTaskExecutor.java:197) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745) 

    Es stellt sich heraus, RoboVm ist nicht kompatibel mit Android Studio 2.3 (noch): https://github.com/MobiDevelop/robovm/issues/115

    Nachdem ich wieder zu Android Studio 2.2.3 gegangen bin, konnte ich die Desktop-Anwendung ganz gut laufen lassen.

    Das Android ist ein Google Android Fan-Website, Alles ├╝ber Android Phones, Android Wear, Android Dev und Android Spiele Apps und so weiter.